import re
regex = re.compile(r"(this is.{0,2}(an.{0,2})?)?(example sentence)", flags=re.IGNORECASE)
test_str = ("blah blah. An example sentence\n"
"blah blah. This is an example sentence\n"
"Something something Example sentence ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")