$re = '/(this is.{0,2}(an.{0,2})?)?(example sentence)/i';
$str = 'blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);