# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\/\/(?:www\.)?youtu(?:\.be\/\S+|be\.com\/watch\?v=\S+)/ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ/gm;t' <<< "https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo"