import Foundation
let pattern = #"https?://(?:www\.)?youtu(?:\.be/\S+|be\.com/watch\?v=\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)