#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?://(?:www\.)?youtu(?:\.be/\S+|be\.com/watch\?v=\S+)"
Local $sString = "https://www.youtube.com/watch?v=**********" & @CRLF & _
"http://www.cyberforum.ru/php-regex/thread2508143.html" & @CRLF & _
"https://youtu.be/**********" & @CRLF & _
"https://www.youtube.com/watch?v=zn9ya1VuZSo"
Local $sSubst = "ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)