// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://(?:www\.)?youtu(?:\.be/\S+|be\.com/watch\?v=\S+)").unwrap();
let string = "https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo";
let substitution = "ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}