use strict;
my $str = 'https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo';
my $regex = qr~https?://(?:www\.)?youtu(?:\.be/\S+|be\.com/watch\?v=\S+)~mp;
my $subst = 'ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";