re = /https?:\/\/(?:www\.)?youtu(?:\.be\/\S+|be\.com\/watch\?v=\S+)/m
str = 'https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo'
subst = 'ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result