package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://(?:www\.)?youtu(?:\.be/\S+|be\.com/watch\?v=\S+)`)
var str = `https://www.youtube.com/watch?v=**********
http://www.cyberforum.ru/php-regex/thread2508143.html
https://youtu.be/**********
https://www.youtube.com/watch?v=zn9ya1VuZSo`
var substitution = "ЗНАЧЕНИЕ-ДЛЯ-ЗАМЕНЫ"
fmt.Println(re.ReplaceAllString(str, substitution))
}