#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))"
Local $sString = "Col A,Col B" & @CRLF & _
"A2: no line breaks,B2: blah blah blah" & @CRLF & _
"A3: line breaks,"B3: blah" & @CRLF & _
"blah" & @CRLF & _
"blah"" & @CRLF & _
"A4: no line breaks,B4: blah blah blah"
Local $sSubst = "[$1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)