import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:,|\\n|^)(\"(?:(?:\"\")*[^\"]*)*\"|[^\",\\n]*|(?:\\n|$))";
final String string = "Col A,Col B\n"
+ "A2: no line breaks,B2: blah blah blah\n"
+ "A3: line breaks,\"B3: blah\n"
+ "blah\n"
+ "blah\"\n"
+ "A4: no line breaks,B4: blah blah blah";
final String subst = "[$1]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}