$re = '/(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))/';
$str = 'Col A,Col B
A2: no line breaks,B2: blah blah blah
A3: line breaks,"B3: blah
blah
blah"
A4: no line breaks,B4: blah blah blah';
$subst = "[$1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;