import Foundation
let pattern = #"(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Col A,Col B
A2: no line breaks,B2: blah blah blah
A3: line breaks,"B3: blah
blah
blah"
A4: no line breaks,B4: blah blah blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)