re = /(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))/
str = 'Col A,Col B
A2: no line breaks,B2: blah blah blah
A3: line breaks,"B3: blah
blah
blah"
A4: no line breaks,B4: blah blah blah'
subst = '[$1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result