use strict;
my $str = 'Col A,Col B
A2: no line breaks,B2: blah blah blah
A3: line breaks,"B3: blah
blah
blah"
A4: no line breaks,B4: blah blah blah';
my $regex = qr/(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))/p;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";