package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:,|\n|^)("(?:(?:"")*[^"]*)*"|[^",\n]*|(?:\n|$))`)
var str = `Col A,Col B
A2: no line breaks,B2: blah blah blah
A3: line breaks,"B3: blah
blah
blah"
A4: no line breaks,B4: blah blah blah`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}