import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w{4,}@+\\w{2,}(.com|.co.uk)$";
final String string = "abcd@ef.com\n"
+ "1111@ef.com\n"
+ "a1cd@ef.com\n"
+ "abcd@1f.com\n"
+ "ab2d@e2.com\n"
+ "abcd@ef.co.uk\n"
+ "abcd@eF.co.uk\n"
+ "a1cd@ef.co.uk\n"
+ "abcd@1f.co.uk\n"
+ "ab2d@e2.co.uk\n"
+ "ab2d@DD.co.uk\n"
+ "ab2d@vv.co.eu\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}