use strict;
my $str = 'abcd@ef.com
1111@ef.com
a1cd@ef.com
abcd@1f.com
ab2d@e2.com
abcd@ef.co.uk
abcd@eF.co.uk
a1cd@ef.co.uk
abcd@1f.co.uk
ab2d@e2.co.uk
ab2d@DD.co.uk
ab2d@vv.co.eu
';
my $regex = qr/^\w{4,}@+\w{2,}(.com|.co.uk)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}