const regex = new RegExp('^\\w{4,}@+\\w{2,}(.com|.co.uk)$', 'gm')
const str = `abcd@ef.com
1111@ef.com
a1cd@ef.com
abcd@1f.com
ab2d@e2.com
abcd@ef.co.uk
abcd@eF.co.uk
a1cd@ef.co.uk
abcd@1f.co.uk
ab2d@e2.co.uk
ab2d@DD.co.uk
ab2d@vv.co.eu
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}