// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w{4,}@+\w{2,}(.com|.co.uk)$").unwrap();
let string = "abcd@ef.com
1111@ef.com
a1cd@ef.com
abcd@1f.com
ab2d@e2.com
abcd@ef.co.uk
abcd@eF.co.uk
a1cd@ef.co.uk
abcd@1f.co.uk
ab2d@e2.co.uk
ab2d@DD.co.uk
ab2d@vv.co.eu
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}