$re = '/^\w{4,}@+\w{2,}(.com|.co.uk)$/m';
$str = 'abcd@ef.com
1111@ef.com
a1cd@ef.com
abcd@1f.com
ab2d@e2.com
abcd@ef.co.uk
abcd@eF.co.uk
a1cd@ef.co.uk
abcd@1f.co.uk
ab2d@e2.co.uk
ab2d@DD.co.uk
ab2d@vv.co.eu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);