#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*:)(.+)(\/.*)$"
Local $sString = "PN:1154007853015C/SH02386M" & @CRLF & _
":123/" & @CRLF & _
"text:value/text" & @CRLF & _
"1:123/1" & @CRLF & _
"" & @CRLF & _
"123/123" & @CRLF & _
"a:123asdf" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")