$re = '/^(.*:)(.+)(\/.*)$/m';
$str = 'PN:1154007853015C/SH02386M
:123/
text:value/text
1:123/1
123/123
a:123asdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);