using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*:)(.+)(\/.*)$";
string input = @"PN:1154007853015C/SH02386M
:123/
text:value/text
1:123/1
123/123
a:123asdf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}