const regex = /^(.*:)(.+)(\/.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*:)(.+)(\\\/.*)$', 'gm')
const str = `PN:1154007853015C/SH02386M
:123/
text:value/text
1:123/1
123/123
a:123asdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}