package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*:)(.+)(\/.*)$`)
var str = `PN:1154007853015C/SH02386M
:123/
text:value/text
1:123/1
123/123
a:123asdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}