import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*:)(.+)(\\/.*)$";
final String string = "PN:1154007853015C/SH02386M\n"
+ ":123/\n"
+ "text:value/text\n"
+ "1:123/1\n\n"
+ "123/123\n"
+ "a:123asdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}