re = /^(.*:)(.+)(\/.*)$/m
str = 'PN:1154007853015C/SH02386M
:123/
text:value/text
1:123/1
123/123
a:123asdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end