#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(DBC-Pillar单)+"
Local $sString = "00013200607-DBC-Pillar单个气孔.csv" & @CRLF & _
"00013200607-DBC-Pillar总气孔.csv" & @CRLF & _
"00013200607-芯片-DBC单个气孔.csv" & @CRLF & _
"00013200607-芯片-DBC总气孔.csv" & @CRLF & _
"00013200607-芯片-Spacer单个气孔.csv" & @CRLF & _
"00013200607-芯片-Spacer总气孔.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")