import re
regex = re.compile(r"(DBC-Pillar单)+", flags=re.MULTILINE)
test_str = ("00013200607-DBC-Pillar单个气孔.csv\n"
"00013200607-DBC-Pillar总气孔.csv\n"
"00013200607-芯片-DBC单个气孔.csv\n"
"00013200607-芯片-DBC总气孔.csv\n"
"00013200607-芯片-Spacer单个气孔.csv\n"
"00013200607-芯片-Spacer总气孔.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")