use strict;
my $str = '00013200607-DBC-Pillar单个气孔.csv
00013200607-DBC-Pillar总气孔.csv
00013200607-芯片-DBC单个气孔.csv
00013200607-芯片-DBC总气孔.csv
00013200607-芯片-Spacer单个气孔.csv
00013200607-芯片-Spacer总气孔.csv';
my $regex = qr/(DBC-Pillar单)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}