$re = '/(DBC-Pillar单)+/m';
$str = '00013200607-DBC-Pillar单个气孔.csv
00013200607-DBC-Pillar总气孔.csv
00013200607-芯片-DBC单个气孔.csv
00013200607-芯片-DBC总气孔.csv
00013200607-芯片-Spacer单个气孔.csv
00013200607-芯片-Spacer总气孔.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);