const regex = /(DBC-Pillar单)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(DBC-Pillar单)+', 'gm')
const str = `00013200607-DBC-Pillar单个气孔.csv
00013200607-DBC-Pillar总气孔.csv
00013200607-芯片-DBC单个气孔.csv
00013200607-芯片-DBC总气孔.csv
00013200607-芯片-Spacer单个气孔.csv
00013200607-芯片-Spacer总气孔.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}