#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)" & @CRLF & _
"(?:\s|^)" & @CRLF & _
"([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)" & @CRLF & _
"(?=\s|$)"
Local $sString = "0.2 2.1 3.1 ab 3 c abc23" & @CRLF & _
"4534.34534345" & @CRLF & _
".456456" & @CRLF & _
"1." & @CRLF & _
"1e545" & @CRLF & _
"1.1e435ff" & @CRLF & _
".1e232" & @CRLF & _
"1.e343" & @CRLF & _
"1231ggg" & @CRLF & _
"112E+12" & @CRLF & _
"4" & @CRLF & _
"5545ggg" & @CRLF & _
"dfgdf.5444" & @CRLF & _
"12312.1231" & @CRLF & _
".1231" & @CRLF & _
"1231" & @CRLF & _
"1.wrr" & @CRLF & _
"1 34345 234 -121" & @CRLF & _
"177" & @CRLF & _
"-1e+ -1e+0 1e-1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")