package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xm)
(?:\s|^)
([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)
(?=\s|$)`)
var str = `0.2 2.1 3.1 ab 3 c abc23
4534.34534345
.456456
1.
1e545
1.1e435ff
.1e232
1.e343
1231ggg
112E+12
4
5545ggg
dfgdf.5444
12312.1231
.1231
1231
1.wrr
1 34345 234 -121
177
-1e+ -1e+0 1e-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}