import re
regex = re.compile((r"(?xm)\n"
r"(?:\s|^)\n"
r"([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)\n"
r"(?=\s|$)"))
test_str = ("0.2 2.1 3.1 ab 3 c abc23\n"
"4534.34534345\n"
".456456\n"
"1.\n"
"1e545\n"
"1.1e435ff\n"
".1e232\n"
"1.e343\n"
"1231ggg\n"
"112E+12\n"
"4\n"
"5545ggg\n"
"dfgdf.5444\n"
"12312.1231\n"
".1231\n"
"1231\n"
"1.wrr\n"
"1 34345 234 -121\n"
"177\n"
"-1e+ -1e+0 1e-1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")