$re = '/(?xm)
(?:\s|^)
([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)
(?=\s|$)/';
$str = '0.2 2.1 3.1 ab 3 c abc23
4534.34534345
.456456
1.
1e545
1.1e435ff
.1e232
1.e343
1231ggg
112E+12
4
5545ggg
dfgdf.5444
12312.1231
.1231
1231
1.wrr
1 34345 234 -121
177
-1e+ -1e+0 1e-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);