import Foundation
let pattern = #"""
(?xm)
(?:\s|^)
([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)
(?=\s|$)
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0.2 2.1 3.1 ab 3 c abc23
4534.34534345
.456456
1.
1e545
1.1e435ff
.1e232
1.e343
1231ggg
112E+12
4
5545ggg
dfgdf.5444
12312.1231
.1231
1231
1.wrr
1 34345 234 -121
177
-1e+ -1e+0 1e-1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)