// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)
(?:\s|^)
([-+]?(?:\b\d+\.\d*|\.?\d+)(?:[eE][-+]?\d+)?)
(?=\s|$)").unwrap();
let string = "0.2 2.1 3.1 ab 3 c abc23
4534.34534345
.456456
1.
1e545
1.1e435ff
.1e232
1.e343
1231ggg
112E+12
4
5545ggg
dfgdf.5444
12312.1231
.1231
1231
1.wrr
1 34345 234 -121
177
-1e+ -1e+0 1e-1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}