#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$"
Local $sString = "Yaw" & @CRLF & _
"yaw" & @CRLF & _
"James Bond" & @CRLF & _
"Monkey D Luffy" & @CRLF & _
"List item" & @CRLF & _
"Mas few def" & @CRLF & _
"Mas no no" & @CRLF & _
"No mas no" & @CRLF & _
"No no mas" & @CRLF & _
"Masa no no" & @CRLF & _
"aa Mdef" & @CRLF & _
"Jamesbondokskdk" & @CRLF & _
"YaW" & @CRLF & _
"Two spaces" & @CRLF & _
"No no no" & @CRLF & _
"abg def ghi " & @CRLF & _
"JamesBond"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")