use strict;
my $str = 'Yaw
yaw
James Bond
Monkey D Luffy
List item
Mas few def
Mas no no
No mas no
No no mas
Masa no no
aa Mdef
Jamesbondokskdk
YaW
Two spaces
No no no
abg def ghi
JamesBond';
my $regex = qr/^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}