const regex = /^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\\b[A-Z]?[a-z]*\\ ?\\b){1,3}$', 'gm')
const str = `Yaw
yaw
James Bond
Monkey D Luffy
List item
Mas few def
Mas no no
No mas no
No no mas
Masa no no
aa Mdef
Jamesbondokskdk
YaW
Two spaces
No no no
abg def ghi
JamesBond`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}