import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\\b[A-Z]?[a-z]*\\ ?\\b){1,3}$";
final String string = "Yaw\n"
+ "yaw\n"
+ "James Bond\n"
+ "Monkey D Luffy\n"
+ "List item\n"
+ "Mas few def\n"
+ "Mas no no\n"
+ "No mas no\n"
+ "No no mas\n"
+ "Masa no no\n"
+ "aa Mdef\n"
+ "Jamesbondokskdk\n"
+ "YaW\n"
+ "Two spaces\n"
+ "No no no\n"
+ "abg def ghi \n"
+ "JamesBond";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}