using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$";
string input = @"Yaw
yaw
James Bond
Monkey D Luffy
List item
Mas few def
Mas no no
No mas no
No no mas
Masa no no
aa Mdef
Jamesbondokskdk
YaW
Two spaces
No no no
abg def ghi
JamesBond";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}