$re = '/^(?=[A-Za-z ]{3,15}$)(?=[A-Za-z ]*[A-Za-z]{3})(?:\b[A-Z]?[a-z]*\ ?\b){1,3}$/m';
$str = 'Yaw
yaw
James Bond
Monkey D Luffy
List item
Mas few def
Mas no no
No mas no
No no mas
Masa no no
aa Mdef
Jamesbondokskdk
YaW
Two spaces
No no no
abg def ghi
JamesBond';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);