using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)#([0-9]+) - ([\w]+) change ([0-9]+) [(]binary[+]Fl[)]";
string input = @"//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}