const regex = new RegExp('(.*)#([0-9]+) - ([\\w]+) change ([0-9]+) [(]binary[+]Fl[)]', 'gm')
const str = `//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}