package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)#([0-9]+) - ([\w]+) change ([0-9]+) [(]binary[+]Fl[)]`)
var str = `//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}