import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)#([0-9]+) - ([\\w]+) change ([0-9]+) [(]binary[+]Fl[)]";
final String string = "//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}