import re
regex = re.compile(r"(.*)#([0-9]+) - ([\w]+) change ([0-9]+) [(]binary[+]Fl[)]", flags=re.MULTILINE)
test_str = "//depot/Flow/05_clean/Defense_Onball/Move_9076_001.fbx#1 - add change 1466 (binary+Fl)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")